summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Vander Stichele <thomas@apestaart.org>2005-11-28 19:58:56 +0000
committerThomas Vander Stichele <thomas@apestaart.org>2005-11-28 19:58:56 +0000
commiteaf17081ca559b93ea5c89692e52b2e0af8dd490 (patch)
tree99419e588689b57d41540db2a5041f206e98696d /Makefile.am
parent9f5ea354239f16a9d2d48dd6cc2b1445ab5128e0 (diff)
Makefile.am: don't run checks if we don't have check
Original commit message from CVS: * Makefile.am: don't run checks if we don't have check * common/check.mak: remove the registry when running make torture * docs/gst/gstreamer-sections.txt: remove second multiply * gst/gstqueue.c: (gst_queue_loop): fix a compile warning when disabling debug
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 890f40bb9..2db63799f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -117,11 +117,21 @@ check-coverage:
echo "Need to reconfigure with --enable-gcov"
endif
+if HAVE_CHECK
check-valgrind:
cd check && make check-valgrind
check-torture:
cd check && make torture
+else
+check-valgrind:
+ echo "You need to install the 'check' library"
+ exit 1
+
+check-torture:
+ echo "You need to install the 'check' library"
+ exit 1
+endif
win32-update:
for f in gstversion.h gstenumtypes.c gstenumtypes.h; do \