summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRobert Relyea <rrelyea@redhat.com>2010-10-03 14:34:43 +0200
committerAlon Levy <alevy@redhat.com>2010-10-03 14:36:55 +0200
commita256875a5947dbea1d6a066698e2948071519714 (patch)
tree47a5100e5df60178ab4eb5b41a1beb83498fafe6 /Makefile.am
parentb1a3c160735ccbf0ba5539e957d400660ebb6ec3 (diff)
passthru and multiple reader support.
New Features, library: - added passthru mode: pass thru can be used either as a card_type and an existing emulator, or as it's own emulator. When used as it's own emulator, only the passhthru card type is supported. Enabling Passhtru is a compile time option (you can build without it). It is still selected for at run-time - added argument parsing code for the NSS emulator. This allows the argument structure to move back to the emulator dependent directory. (This allows other emulators to be implemented without the application needing to know about emulator specific stuff. - added functions to get the reader name and id, and have the caller set the reader id. - added vevent_get_next_vevent() - non-blocking event grabber. - added string arguments to the card_type_init functions (currently not used). - added VCARD_DIRECT card type which passes all the apdus the the card type's last applet. - added function to optionally get the ATR from the card type emul instead of the emulator. NOTE: apps should now call vcard_get_atr rather than vcard_emul_get_atr. - Fixed the VCARD_ATR_PREFIX to take a constant signifying the number of additional historical bytes for the card emulator. - added usage statment. New Features, vscclient.c - vscclient now handles multiple readers, assuming multiple readers are defined in qemu. - vscclient now calls the emul to parse the command line arguments. - vscclient has an option to enable passthru - vscclient now passes the real reader name to qemu - vscclient has 2 new commands: debug [level] -- sets the various levels of debugging output on the fly. list -- lists all the active readers, their card state and their name.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 5f6f4e9..beb45b8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,12 +3,15 @@ NULL =
INCLUDES= \
-I. \
$(NSS_CFLAGS) \
+ $(PCSC_CFLAGS) \
+ $(USE_PASSTHRU) \
$(NULL)
lib_LTLIBRARIES = libcac_card.la
libcac_card_la_LIBADD = \
$(NSS_LIBS) \
+ $(PCSC_LIBS) \
$(NULL)
@@ -16,6 +19,7 @@ libcac_card_la_SOURCES= \
cac.c \
card_7816.c \
event.c \
+ passthru.c \
vcard_emul_nss.c \
vcard_emul_type.c \
vcard.c \