summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Herrmann <dh.herrmann@gmail.com>2014-05-14 15:31:03 +0200
committerDavid Herrmann <dh.herrmann@gmail.com>2014-05-14 15:31:03 +0200
commit3ccb60ed95b2e70137212fb7ce68f1f94b9ce421 (patch)
tree2d6c6ed900248d0a1d42c4ae511d303fdec3517a /Makefile.am
parenta214453f2d31fde9d17c0b32f04722d143fa030a (diff)
Add glyph-headersHEADmaster
Similar to a global header, we now add a header to each glyph. This makes extending single glyphs much easier and we don't have to append it at the end. Also replace the previous test with a more advanced one. Signed-off-by: David Herrmann <dh.herrmann@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am14
1 files changed, 7 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 494c048..39bfb42 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -77,7 +77,7 @@ src/mmap-unifont.bin: src/compile-unifont.py src/unifont.hex
src/mmap-unifont.cmp: src/compile-unifont.py src/mmap-unifont.bin
$(AM_V_GEN)cat $(top_srcdir)/src/mmap-unifont.bin | $(PYTHON) $< verify >$@
-update-unifont: src/mmap-unifont.bin src/mmap-unifont.cmp
+test-unifont: src/mmap-unifont.bin src/mmap-unifont.cmp
@RET=`diff -u src/unifont.hex src/mmap-unifont.cmp | wc -l` ; \
if test "x$$?" != "x0" -o "x$$RET" != "x0" ; then \
echo "Generated Unifont-file differs from original; generator probably broken" ; \
@@ -97,7 +97,7 @@ update-unifont: src/mmap-unifont.bin src/mmap-unifont.cmp
if BUILD_HAVE_CHECK
MEMTESTS += \
- test-glyphs
+ test-example
check_PROGRAMS += \
$(MEMTESTS) \
test-valgrind
@@ -116,10 +116,10 @@ test_cflags = \
test_lflags = \
$(AM_LDFLAGS)
-test_glyphs_SOURCES = test/test-glyphs.c $(test_sources)
-test_glyphs_CPPFLAGS = $(test_cflags)
-test_glyphs_LDADD = $(test_libs)
-test_glyphs_LDFLAGS = $(test_lflags)
+test_example_SOURCES = test/test-example.c $(test_sources)
+test_example_CPPFLAGS = $(test_cflags)
+test_example_LDADD = $(test_libs)
+test_example_LDFLAGS = $(test_lflags)
test_valgrind_SOURCES = test/test-valgrind.c $(test_sources)
test_valgrind_CPPFLAGS = $(test_cflags)
@@ -145,7 +145,7 @@ memcheck: memcheck-verify
TPHONY += memcheck memcheck-verify
-distcheck-hook: memcheck
+distcheck-hook: test-unifont memcheck
#
# Phony targets