summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Herrmann <dh.herrmann@gmail.com>2014-02-11 11:34:33 +0100
committerDavid Herrmann <dh.herrmann@gmail.com>2014-02-11 11:34:33 +0100
commit650920082c78df8cea2c4e77a29563d7717e0bca (patch)
tree4a5808dd2f67c93ea554995c054461fbae05448b /Makefile.am
parent0ce874d7cee5e9da7f37aeebb97d24732c8465a0 (diff)
miraclectl: use readline
Add readline support to miraclectl so we can have interactive commands. This rewrites huge parts of miraclectl but hopefully makes it future proof so no such rewrite will be needed again. Signed-off-by: David Herrmann <dh.herrmann@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index cc2f380..141a680 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -119,6 +119,7 @@ miraclectl_CPPFLAGS = \
$(DEPS_CFLAGS)
miraclectl_LDADD = \
libshl.la \
+ -lreadline \
$(DEPS_LIBS)
miraclectl_LDFLAGS = $(AM_LDFLAGS)