summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Herrmann <dh.herrmann@googlemail.com>2013-01-24 20:32:40 +0100
committerDavid Herrmann <dh.herrmann@googlemail.com>2013-01-24 20:32:40 +0100
commit4f8edb38c8171ce66d116c1f426fae195b837b97 (patch)
tree60a7b5e57313b02f4f486136c6dc7a6caac7ce5c /Makefile.am
parent6a7cbd8fc06e41eb8fa5212394123de7d65159dd (diff)
wlt: link font library statically
We need the font layer to build wlterm. However, the font layer depends on kmscon internal module handling so we cannot do this. To avoid this, we simply provide dummy handlers for the kmscon_module_* layer and link it anyway. This is kind of ugly but works, yey! Signed-off-by: David Herrmann <dh.herrmann@googlemail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b861521..2e464a5 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -583,6 +583,8 @@ wlterm_SOURCES = \
$(SHL_ARRAY) \
$(SHL_DLIST) \
$(SHL_HOOK) \
+ $(SHL_REGISTER) \
+ $(SHL_HASHTABLE) \
src/wlt_main.h \
src/wlt_main.c \
src/wlt_toolkit.h \
@@ -596,13 +598,19 @@ wlterm_SOURCES = \
src/conf.h \
src/conf.c \
src/pty.h \
- src/pty.c
+ src/pty.c \
+ src/font.h \
+ src/font.c \
+ src/font_8x16.c \
+ src/font_pango.c
wlterm_CPPFLAGS = \
$(AM_CPPFLAGS) \
$(WAYLAND_CFLAGS) \
+ $(PANGO_CFLAGS) \
$(XKBCOMMON_CFLAGS)
wlterm_LDADD = \
$(WAYLAND_LIBS) \
+ $(PANGO_LIBS) \
$(XKBCOMMON_LIBS) \
libeloop.la \
libtsm.la \