summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Herrmann <dh.herrmann@googlemail.com>2013-01-24 16:42:03 +0100
committerDavid Herrmann <dh.herrmann@googlemail.com>2013-01-24 16:42:03 +0100
commit0f206cc5b58685c4b4cb9e17374f6265b56cc038 (patch)
tree2e25fe1e915492c1624eaba425ee7440eaf3eeab /Makefile.am
parentf289349ef9a0a14566c50d666e698c4c97912e76 (diff)
uterm: drm: rename to drm3d
This renames the video-drm backend to drm3d (which was already used internally). This is a pure rename, the code-logic stays the same. This also puts the drm3d backend into a module so we can more easily load it during runtime. Signed-off-by: David Herrmann <dh.herrmann@googlemail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index a17ab09..b861521 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -282,9 +282,11 @@ libuterm_la_CPPFLAGS += $(DRM_CFLAGS)
libuterm_la_LIBADD += $(DRM_LIBS)
endif
-if BUILD_ENABLE_VIDEO_DRM
+if BUILD_ENABLE_VIDEO_DRM3D
libuterm_la_SOURCES += \
- src/uterm_video_drm.c \
+ src/uterm_drm3d_internal.h \
+ src/uterm_drm3d_video.c \
+ src/uterm_drm3d_render.c \
src/static_gl.h \
src/static_gl_math.c \
src/static_gl_shader.c
@@ -309,7 +311,7 @@ UTERM_DRM_SHARED_SRC = \
if BUILD_ENABLE_VIDEO_DRM2D
libuterm_la_SOURCES += $(UTERM_DRM_SHARED_SRC)
else
-if BUILD_ENABLE_VIDEO_DRM
+if BUILD_ENABLE_VIDEO_DRM3D
libuterm_la_SOURCES += $(UTERM_DRM_SHARED_SRC)
endif
endif