summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 1 insertions, 9 deletions
diff --git a/configure.ac b/configure.ac
index 078c9fa..ff0129a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,6 +35,7 @@ LT_INIT([win32-dll disable-static pic-only])
AC_CANONICAL_HOST
AX_CXX_COMPILE_STDCXX_11
+AX_GCC_FUNC_ATTRIBUTE([format])
DLP_FALLTHROUGH
PKG_PROG_PKG_CONFIG([0.20])
@@ -224,15 +225,6 @@ AS_IF([test "x$enable_debug" = "xyes"], [
DEBUG_CXXFLAGS="-DDEBUG -g"
CXXFLAGS="$CXXFLAGS -O0"
CFLAGS="$CFLAGS -O0"
- AC_MSG_CHECKING([if the compiler supports __attribute__((__format__()))])
- AC_COMPILE_IFELSE([AC_LANG_SOURCE([
- void print(const char *, ...) __attribute__((__format__(__printf__, 1, 2)));
- ])], [
- AC_MSG_RESULT([yes])
- AC_DEFINE([HAVE_ATTRIBUTE_FORMAT], [1], [Define to 1 if your compiler supports __attribute__((__format__()))])
- ], [
- AC_MSG_RESULT([no])
- ])
], [
DEBUG_CXXFLAGS="-DNDEBUG"
])