summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJames Cloos <cloos@jhcloos.com>2007-12-06 15:51:07 -0500
committerJames Cloos <cloos@jhcloos.com>2007-12-06 15:51:07 -0500
commitc0246278393f9440717eea292a3d31440f7972dd (patch)
tree826977b9e7c1f6f93d330865372e68de5dc40f52 /Makefile.am
parent3b064b7206a84aae873743b706c41324a67c1f2c (diff)
Add missing PHONY line for automatic ChangeLog generation
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index babc2f3..5becb5e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -101,6 +101,8 @@ CLEANFILES = xinitrc startx $(appman_DATA)
EXTRA_DIST = xinitrc.cpp startx.cpp $(appman_PRE) \
startx.cmd xinitrc.cmd xinit.def ChangeLog autogen.sh
+.PHONY: ChangeLog
+
ChangeLog:
(GIT_DIR=$(top_srcdir)/.git git-log > .changelog.tmp && mv .changelog.tmp ChangeLog; rm -f .changelog.tmp) || (touch ChangeLog; echo 'git directory not found: installing possibly empty changelog.' >&2)