summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJeremy Huddleston <jeremyhu@freedesktop.org>2009-09-02 10:43:25 -0700
committerJeremy Huddleston <jeremyhu@freedesktop.org>2009-09-02 10:43:25 -0700
commit78d181dc74ffb3e67ee0d90780b86e00e03073eb (patch)
treeaf4fc08567fb47e2b7f8c053cdb2dedd5174d5f8 /Makefile.am
parent33c3dae16b632ab56b6b361273a48079eb0a41c4 (diff)
launchd: Added --with-launchd-id-prefix option to set non-standard launchd id prefix (org.x is still default)
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 951d51a..a9ae6c1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -56,10 +56,14 @@ CPP_FILES_FLAGS = \
-DXINITDIR=$(XINITDIR) $(PROGCPPDEFS) -DLIBDIR=$(libdir) \
-DSHELL_CMD=$(SHELL_CMD) $(STARTX_COOKIE_FLAGS) \
-D__libexecdir__="$(libexecdir)" \
- -D__bindir__="$(bindir)"
+ -D__bindir__="$(bindir)" \
+ -DLAUNCHD_ID_PREFIX=\"$(launchdidprefix)\"
if LAUNCHD
-launchagents_PRE = org.x.startx.plist.cpp
+$(launchdidprefix).startx.plist.cpp: org.x.startx.plist.cpp
+ cp $< $@
+
+launchagents_PRE = $(launchdidprefix).startx.plist.cpp
launchagents_DATA = $(launchagents_PRE:plist.cpp=plist)
SUBDIRS = privileged_startx