summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2009-10-13 18:37:00 -0700
committerAlan Coopersmith <alan.coopersmith@sun.com>2009-10-13 18:37:00 -0700
commiteb4dbb8aac0858e1ee7169b2e0b90d5e3223de59 (patch)
tree05af590177b7e0bb8c57e0d94a326e3f0ec99407 /configure.ac
parente609e939f8b2573ac50bdd317733a2fef194965a (diff)
Use font-utils 1.1 macros to find encodings path
Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 6 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index fc28ef9..72bf055 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,11 +37,12 @@ AC_PROG_CC
AC_PROG_LIBTOOL
XORG_CWARNFLAGS
-encodingsdir=${libdir}/X11/fonts/encodings
-AC_ARG_WITH(encodingsdir, AC_HELP_STRING([--with-encodingsdir=<pathname>],
- [Path to font encodings]), [encodingsdir="$withval"])
-ENCODINGSDIR="$encodingsdir"
-AC_SUBST(ENCODINGSDIR)
+# Require X.Org's font util macros 1.1 or later for XORG_FONTROOTDIR
+m4_ifndef([XORG_FONT_MACROS_VERSION],
+ [m4_fatal([must install X.Org font-util 1.1 or later before running autoconf/autogen])])
+XORG_FONT_MACROS_VERSION(1.1)
+
+XORG_FONTSUBDIR([ENCODINGSDIR], [encodingsdir], [encodings])
# zlib