summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorPaulo Cesar Pereira de Andrade <pcpa@mandriva.com.br>2009-01-09 16:34:13 -0200
committerPaulo Cesar Pereira de Andrade <pcpa@mandriva.com.br>2009-01-09 16:34:13 -0200
commit49336f1b6fa5d8dc8a9ae3e8d286b061f0d2914c (patch)
tree4a1948dc2ae78bdda29964d59298d602a91e214c /Makefile.am
parent498cce64f12de67271316417de821460e8eee066 (diff)
Ansification and compile warning fixes.
Code that already have a header with the proper prototype is safe to ansify. This uses XORG_CHANGELOG macro to properly work with the "git-log" to "git log" change (required to pass "make distcheck"), uses the XORG_CWARNFLAGS macro, and doesn't generate any compile warnings from gcc 4.3 and sparse.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 14e8ed0..e419649 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -80,13 +80,13 @@ $(LINTLIB): $(libXdmcp_la_SOURCES) $(nodist_libXdmcp_la_SOURCES)
$(LINT) -y -oXdmcp -x $(ALL_LINT_FLAGS) $(libXdmcp_la_SOURCES) $(nodist_libXdmcp_la_SOURCES)
endif MAKE_LINT_LIB
-if MAINTAINER_MODE
+MAINTAINERCLEANFILES=ChangeLog
+
.PHONY: ChangeLog
ChangeLog:
- GIT_DIR=${srcdir}/.git git-log > ChangeLog
+ $(CHANGELOG_CMD)
dist-hook: ChangeLog
-endif MAINTAINER_MODE
CLEANFILES=$(lintlib_DATA)