summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMartin Szulecki <opensuse@sukimashita.com>2008-03-13 20:38:18 +0100
committerDanny Kukawka <danny.kukawka@web.de>2008-03-13 20:38:18 +0100
commitee68b0ebfcadf60bf31dd1b3163f52741dce25f1 (patch)
tree46d32fdd68c152a69cb3744696df46540b12c936 /configure.in
parentb659dddba0cefe6d70ed297a396bae965e4f9506 (diff)
add iMac (x86 linux) backlight addon
Added iMac (x86 linux) backlight addon. On my way to control the hardcore radioactive backlight of the newer iMac 24" aluminum models some older code from the mactel guys appeared to work (while the brightness level range lacks on the 24" but is good on the 20" ones, compared to Mac OS). I glued a patch which exposes the control like the other Macbook and Macbook Pro addons. People reported that it apparently also worked on other iMac models which I added to the corresponding fdi. With the lately upstreamed hid patches to support the new aluminum apple keyboard (really nice!) one can control the backlight of the display nicely.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in25
1 files changed, 25 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index f4a1aac7..013e2b32 100644
--- a/configure.in
+++ b/configure.in
@@ -838,6 +838,30 @@ elif test "x$with_macbook" = "x" ; then
fi
AM_CONDITIONAL(BUILD_MACBOOK, [test x$BUILD_MACBOOK = xyes])
+dnl imac backlight
+AC_ARG_WITH([imac],
+ AS_HELP_STRING([--with-imac],
+ [Whether to build iMac (x86 only) backlight (auto)]))
+BUILD_IMAC=no
+if test "x$with_imac" = "xyes" ; then
+ BUILD_IMAC=yes
+elif test "x$with_imac" = "x" ; then
+ case "${HALD_BACKEND}" in
+ linux)
+ case "${host}" in
+ i[[3456]]86-*-*|x86_64-*-*)
+ BUILD_IMAC=yes
+ ;;
+ *)
+ ;;
+ esac
+ ;;
+ *)
+ ;;
+ esac
+fi
+AM_CONDITIONAL(BUILD_IMAC, [test x$BUILD_IMAC = xyes])
+
AC_ARG_WITH([omap],
AS_HELP_STRING([--with-omap],
[Whether to build OMAP utils (auto)]))
@@ -1064,6 +1088,7 @@ echo "
Macbook backlight support: ${BUILD_MACBOOK} (Linux only, x86 only, requires libpci)
Macbook Pro utils: ${BUILD_MACBOOKPRO} (Linux only, x86 only, requires libpci)
+ iMac backlight support: ${BUILD_IMAC} (Linux only, x86)
OMAP utils: ${BUILD_OMAP} (Linux only, arm only)
CPU frequency scaling: ${BUILD_CPUFREQ} (Linux only)
Re-map multimedia keys: ${BUILD_KEYMAPS} (Linux only, requires gperf)