summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlan Coopersmith <alan.coopersmith@sun.com>2010-01-19 14:54:04 -0800
committerAlan Coopersmith <alan.coopersmith@sun.com>2010-01-19 14:56:11 -0800
commit30a19b75cc82b8e04c45e6684b84f9a4ccc0505b (patch)
treed067f469d07ceb99580135c47c8b7305b4099ed1 /configure.ac
parentbd011784c0609f1fd03dcb784744c8f5cdef33da (diff)
Fix configure with --disable-dri
AM_CONDITIONAL calls can't be made inside if statements, since automake won't know what to do when the if isn't true. Signed-off-by: Alan Coopersmith <alan.coopersmith@sun.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 3 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2d64ff8..6155868 100644
--- a/configure.ac
+++ b/configure.ac
@@ -140,7 +140,6 @@ if test "$DRI" = yes; then
save_CFLAGS="$CFLAGS"
CFLAGS="$XORG_CFLAGS $DRI_CFLAGS $CFLAGS"
- AM_CONDITIONAL(DRM_MODE, test x$DRM_MODE = xyes)
if test "$DRM_MODE" = yes; then
AC_CHECK_HEADER(xf86drmMode.h,[DRM_MODE=yes],[DRM_MODE=no],[#include <stdint.h>
#include <stdlib.h>])
@@ -157,7 +156,10 @@ if test "$DRI" = yes; then
fi
fi
CFLAGS="$save_CFLAGS"
+else
+ DRM_MODE=no
fi
+AM_CONDITIONAL(DRM_MODE, test x$DRM_MODE = xyes)
save_CFLAGS="$CFLAGS"
CFLAGS="$XORG_CFLAGS"