summaryrefslogtreecommitdiff
path: root/supplicant/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'supplicant/Makefile.am')
-rw-r--r--supplicant/Makefile.am29
1 files changed, 29 insertions, 0 deletions
diff --git a/supplicant/Makefile.am b/supplicant/Makefile.am
new file mode 100644
index 0000000..dd953cb
--- /dev/null
+++ b/supplicant/Makefile.am
@@ -0,0 +1,29 @@
+sup_gz = wpa_supplicant-1.0-rc3.tar.gz
+sup_patch = wpa_supplicant-0.7.2-generate-libeap-peer.patch
+sup_path = $(abs_srcdir)/wpa_supplicant-1.0-rc3
+
+libeap.stamp:
+ rm -rf $(sup_path)
+ tar -xzf $(sup_gz)
+ patch -p0 -b --suffix .wimax < $(sup_patch)
+ cd $(sup_path)/src/eap_peer && ln -sf ../utils util
+ cd $(sup_path)/src/eap_peer && ln -sf ../crypto crypto
+ cd $(sup_path)/src/eap_peer && ln -sf ../common common
+ cd $(sup_path)/wpa_supplicant && \
+ make -C ../src/eap_peer && \
+ cd $(sup_path)/src/eap_peer && \
+ ln -sf libeap.so.0.0.0 libeap.so && \
+ ln -sf libeap.so.0.0.0 libeap.so.0 && \
+ touch $(abs_srcdir)/libeap.stamp
+
+all: libeap.stamp
+
+install-exec-local: libeap.stamp
+ mkdir -p $(libdir)/wimax/
+ cp $(sup_path)/src/eap_peer/libeap.so $(DESTDIR)$(libdir)/wimax/
+ cp $(sup_path)/src/eap_peer/libeap.so.0 $(DESTDIR)$(libdir)/wimax/
+
+CLEANFILES = libeap.stamp $(sup_path)/src/eap_peer/*.so*
+
+EXTRA_DIST = $(sup_gz) $(sup_patch)
+