summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorInaky Perez-Gonzalez <inaky.perez-gonzalez@intel.com>2010-04-13 16:00:33 -0700
committerInaky Perez-Gonzalez <inaky.perez-gonzalez@intel.com>2010-04-13 17:04:25 -0700
commit96335456c1e8610544ca0d6121fbea3ede2e2ec5 (patch)
tree19940b9e74d97b9a4cc19d24dc71650745e9802e /configure.ac
parenteea52bd62bd27069199925df0357473c24caa2c7 (diff)
autoconf: introduce --enable-bindb
Enable a configuration switch to select between a build with binary databases or clear texts. Future commits will introduce changes in the automake structure to use it. Signed-off-by: Inaky Perez-Gonzalez <inaky.perez-gonzalez@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index fa034aa..fda3586 100644
--- a/configure.ac
+++ b/configure.ac
@@ -124,6 +124,17 @@ AC_ARG_ENABLE(instrument,
AC_SUBST(USE_INST, "0")
])
+AC_ARG_ENABLE(bindb,
+ AC_HELP_STRING([--enable-bindb],[enable support for binary databases (disabled by default)]),
+ __BINDB_ENABLED=$enable_bindb,
+ __BINDB_ENABLED=no)
+if test x$__BINDB_ENABLED = xyes
+then
+ AC_MSG_RESULT(Database support will be in binary format)
+else
+ AC_MSG_RESULT(Database support will be in clear text format)
+fi
+AM_CONDITIONAL([BINDB_ENABLED], [test x$__BINDB_ENABLED = xyes])
curr_dir=`pwd`
cd $srcdir/InfraStack/OSDependent/Linux/InfraStackModules/CommonAPIHeaders