summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2009-05-09 12:45:04 -0700
committerDan Nicholson <dbn.lists@gmail.com>2009-05-09 16:37:18 -0700
commitceeb2c4270df4b95298ed240a418a488783c1afd (patch)
tree842047bb4e24963f5b79ead7339b68d365fae663 /configure.ac
parentd2d6bfba199f56e46d8aba3e86463fa8b367f41d (diff)
xts5: Use pkg-config to get X libraries
We need to link the xts libraries and test applications with X libraries. This was being defined in common.mk as *SYSLIBS, but now the convention is to use the <var>_{CFLAGS,LIBS} used by PKG_CHECK_MODULES. A couple of the existing CFLAGS variables needed to be renamed to avoid conflicting with the pkg-config variables. This is all still pretty messy in common.mk, and should be cleaned up eventually.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index b0ee9274..2162bbe7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -40,7 +40,10 @@ AC_PROG_LIBTOOL
AC_PROG_CC
#AM_PROG_CC_C_O
-PKG_CHECK_MODULES(XORG, x11 xproto)
+PKG_CHECK_MODULES([XTS], [x11 xext xi xtst])
+PKG_CHECK_MODULES([XP], [x11 xext xi xtst])
+PKG_CHECK_MODULES([XT], [x11 xext xt xtst])
+dnl PKG_CHECK_MODULES([XAW], [x11 xext xt xtst xaw7])
# Checks for header files.
AC_HEADER_STDC