summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2009-05-27 23:32:56 -0700
committerDan Nicholson <dbn.lists@gmail.com>2009-05-27 23:32:56 -0700
commit990c83b2d49bc4d58ad69fa626fedac2fb4052e2 (patch)
tree4eeac0ac2ff4806aef0d836ac0b2e5f5406277da /configure.ac
parentceb977c9c5436472a37bec3410abb473e7860bb2 (diff)
Compile objects in the same subdirectory as the sources
For the tests, we want to just have top-level Makefiles and build the sources in their own subdirectory. Typically, automake would create the object files at the top-level, but this can cause conflicts when the source files have the same name. Use the subdir-objects automake option and enable the necessary AM_PROG_CC_C_O macro.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 0f7051e4..9724866e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -28,7 +28,7 @@ AC_INIT([xtest],
AC_CONFIG_SRCDIR([Makefile.am])
AC_CONFIG_AUX_DIR(.)
-AM_INIT_AUTOMAKE([dist-bzip2 foreign])
+AM_INIT_AUTOMAKE([dist-bzip2 foreign subdir-objects])
AM_MAINTAINER_MODE
@@ -38,7 +38,7 @@ AM_CONFIG_HEADER([config.h])
AC_DISABLE_STATIC
AC_PROG_LIBTOOL
AC_PROG_CC
-#AM_PROG_CC_C_O
+AM_PROG_CC_C_O
PKG_CHECK_MODULES([XTS], [x11 xext xi xtst])
PKG_CHECK_MODULES([XP], [x11 xext xi xtst])