summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDan Nicholson <dbn.lists@gmail.com>2009-05-19 23:37:21 -0700
committerDan Nicholson <dbn.lists@gmail.com>2009-05-19 23:37:21 -0700
commit1b74754739b811f61dd133b8e5691326b74c308f (patch)
tree75eea6d9788acb49c9beb61e2b473b8311548a12 /configure.ac
parenta7bbab323a3e0e8740171ed5aaba2b23218ddcdd (diff)
Error if Xlib does not have _XConnectDisplay
Unfortunately, XTest uses _XConnectDisplay to connect to the server and this is only available in non-xcb Xlib. Hopefully this can be fixed someday.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 7e185074..0f7051e4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -45,6 +45,15 @@ PKG_CHECK_MODULES([XP], [x11 xext xi xtst])
PKG_CHECK_MODULES([XT], [x11 xext xt xtst])
dnl PKG_CHECK_MODULES([XAW], [x11 xext xt xtst xaw7])
+dnl Sadly, we need an Xlib with _XConnectDisplay, and this means a
+dnl non-xcb Xlib.
+_save_LDFLAGS=$LDFLAGS
+LDFLAGS="$LDFLAGS `$PKG_CONFIG --libs-only-L x11 2>/dev/null`"
+AC_CHECK_LIB([X11], [_XConnectDisplay], [],
+ [AC_MSG_ERROR([XTest requires an Xlib with _XConnectDisplay]
+ [Try building libX11 --without-xcb])])
+LDFLAGS=$_save_LDFLAGS
+
# Checks for header files.
AC_HEADER_STDC