summaryrefslogtreecommitdiff
path: root/stc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'stc/Makefile.am')
-rw-r--r--stc/Makefile.am16
1 files changed, 2 insertions, 14 deletions
diff --git a/stc/Makefile.am b/stc/Makefile.am
index 9ea6aaa..e3d8bbc 100644
--- a/stc/Makefile.am
+++ b/stc/Makefile.am
@@ -51,6 +51,7 @@ libstc_1include_HEADERS= \
stcerror.h \
stcitem.h \
stcmonitor.h \
+ stcoperation.h \
$(NULL)
libstc_1_la_SOURCES = \
@@ -59,6 +60,7 @@ libstc_1_la_SOURCES = \
stcerror.h stcerror.c \
stcitem.h stcitem.c \
stcmonitor.h stcmonitor.c \
+ stcoperation.h stcoperation.c \
stcprivate.h \
stcmount.h stcmount.c \
stcmountmonitor.h stcmountmonitor.c \
@@ -130,26 +132,12 @@ pkgconfig_DATA = stc-1.pc
# ----------------------------------------------------------------------------------------------------
-configdir = $(sysconfdir)
-config_DATA = stc.conf
-
-# ----------------------------------------------------------------------------------------------------
-
CLEANFILES =
EXTRA_DIST = \
$(profile_SCRIPTS) \
- stc.conf.in \
stc-1.pc.in \
$(NULL)
clean-local :
rm -f *~ $(BUILT_SOURCES)
-
-# By default, /etc/stc.conf and /etc/stc.conf.d are world-readable. Individual files
-# in /etc/stc.conf.d can be made readable only by uid 0 etc.
-#
-install-exec-hook:
- -chmod 644 $(DESTDIR)$(sysconfdir)/stc.conf
- mkdir -p $(DESTDIR)$(sysconfdir)/stc.conf.d
- -chmod 755 $(DESTDIR)$(sysconfdir)/stc.conf.d