summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Zeuthen <davidz@redhat.com>2010-05-16 09:29:29 -0400
committerDavid Zeuthen <davidz@redhat.com>2010-05-16 09:29:29 -0400
commit54c48cf622f3ac86abac0776eea6db7c8f46df7a (patch)
tree34c0ce2bbf8eb3c9df62ddc26b82e1543697996b /configure.ac
parent6748bd391faf982b88aeda9197c7dcceaaea58b9 (diff)
Setup docs
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6848884..c6de8c1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,6 +7,7 @@ AM_MAINTAINER_MODE
AC_PROG_CC
AC_ISC_POSIX
AC_HEADER_STDC
+AM_PROG_LIBTOOL
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
@@ -83,6 +84,8 @@ if test "x$GCC" = "xyes"; then
changequote([,])dnl
fi
+GTK_DOC_CHECK([1.11])
+
PKG_CHECK_MODULES(GLIB2, glib-2.0 gio-2.0)
AC_SUBST(GLIB2_CFLAGS)
AC_SUBST(GLIB2_LIBS)
@@ -90,6 +93,7 @@ AC_SUBST(GLIB2_LIBS)
AC_OUTPUT([
Makefile
src/Makefile
+doc/Makefile
])
echo "
@@ -111,4 +115,5 @@ echo "
cppflags: ${CPPFLAGS}
Maintainer mode: ${USE_MAINTAINER_MODE}
+ Building api docs: ${enable_gtk_doc}
"