summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRené Stadler <mail@renestadler.de>2008-05-08 17:04:57 +0300
committerRené Stadler <mail@renestadler.de>2008-05-08 17:04:57 +0300
commit1c947d21c1c2a2ebad522273b8d0ca6fef1dd208 (patch)
treea15456ecb98a5357b307455dbdd3fa1783307b1f /setup.py
parentd8d759d36dcd3d8050ae4da4c05e1832413d330b (diff)
Add Tango style contributed app icon
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py17
1 files changed, 14 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 99510c0..056604c 100755
--- a/setup.py
+++ b/setup.py
@@ -322,14 +322,25 @@ cmdclass = {"build" : build_custom,
"distcheck" : distcheck,
"tests" : tests}
+icons = []
+for size in ("16x16", "22x22", "24x24", "32x32", "scalable",):
+ base_source = "data/icons/hicolor/%s/apps/gst-inspector" % (size,)
+ sources = []
+ for ext in ("png", "svg",):
+ source = "%s.%s" % (base_source, ext,)
+ # There's no svg for 24x24.
+ if os.path.exists (source):
+ sources.append (source)
+ if sources:
+ target = "share/icons/hicolor/%s/apps" % (size,)
+ icons.append ((target, sources,))
+
setup (cmdclass = cmdclass,
packages = ["GstInspector"],
scripts = ["gst-inspector"],
data_files = [("share/gst-inspector", ["data/gst-inspector.glade",
- "data/gst-inspector.ui"],),
- ("share/icons/hicolor/48x48/apps", ["data/gst-inspector.png"],),
- ("share/icons/hicolor/scalable/apps", ["data/gst-inspector.svg"],)],
+ "data/gst-inspector.ui"],)] + icons,
name = "gst-inspector",
version = "0.4",