summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndres Gomez <agomez@igalia.com>2014-10-07 17:32:17 +0300
committerIago Toral Quiroga <itoral@igalia.com>2014-10-15 08:59:12 +0200
commit657764c21c1339132b6ef381436b9200839dc227 (patch)
tree77ad825210affb72c7fda508575079eb9e9427e5 /configure.ac
parent8cf6482c3da9493dacf4a6a495ae3c0193cf75a7 (diff)
configure.ac: check for libexpat when no pkg-config is available
Previously, when no pkg-config was available for libexpat we would just add the needed linking flags without any extra check. Now, we check that the library and the headers are also installed in the building environment. Reviewed-by: Emil Velikov <emil.l.velikov@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 7 insertions, 8 deletions
diff --git a/configure.ac b/configure.ac
index 59b90e6cbf..0ed9325449 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1126,14 +1126,13 @@ if test "x$enable_dri" = xyes; then
fi
# Check for expat
- PKG_CHECK_EXISTS([expat], [have_expat=yes], [have_expat=no])
- if test "x$have_expat" = "xyes"; then
- PKG_CHECK_MODULES([EXPAT], [expat], [],
- AC_MSG_ERROR([Expat required for DRI.]))
- else
- # expat version 2.0 and earlier do not provide expat.pc
- EXPAT_LIBS=-lexpat
- fi
+ PKG_CHECK_MODULES([EXPAT], [expat], [],
+ # expat version 2.0 and earlier do not provide expat.pc
+ [AC_CHECK_HEADER([expat.h],[],
+ [AC_MSG_ERROR([Expat headers required for DRI not found])])
+ AC_CHECK_LIB([expat],[XML_ParserCreate],[],
+ [AC_MSG_ERROR([Expat library required for DRI not found])])
+ EXPAT_LIBS="-lexpat"])
DRICOMMON_NEED_LIBDRM=no
# If we are building any DRI driver other than swrast.