summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorIan Romanick <ian.d.romanick@intel.com>2010-02-25 17:17:23 -0800
committerIan Romanick <ian.d.romanick@intel.com>2010-02-25 17:17:23 -0800
commitd59673c9de9f14e6aefcdb0b06751d935385c4aa (patch)
tree6b4540b0d65a3db3a281f42c366d1b9c0715caf8 /Makefile.am
parente41a1cd4d534639272938210c5491077688ccd37 (diff)
autoconf for the ...
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am39
1 files changed, 39 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..28d9c3c
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,39 @@
+# Copyright © 2010 Intel Corporation
+# All Rights Reserved.
+#
+# Permission is hereby granted, free of charge, to any person obtaining a
+# copy of this software and associated documentation files (the "Software"),
+# to deal in the Software without restriction, including without limitation
+# on the rights to use, copy, modify, merge, publish, distribute, sub
+# license, and/or sell copies of the Software, and to permit persons to whom
+# the Software is furnished to do so, subject to the following conditions:
+#
+# The above copyright notice and this permission notice (including the next
+# paragraph) shall be included in all copies or substantial portions of the
+# Software.
+#
+# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+# FITNESS FOR A PARTICULAR PURPOSE AND NON-INFRINGEMENT. IN NO EVENT SHALL
+# AUTHORS, COPYRIGHT HOLDERS, AND/OR THEIR SUPPLIERS BE LIABLE FOR ANY CLAIM,
+# DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR
+# OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE
+# USE OR OTHER DEALINGS IN THE SOFTWARE.
+
+AUTOMAKE_OPTIONS = foreign
+
+bin_PROGRAMS = glsl
+glsl_SOURCES = symbol_table.c hash_table.c glsl_types.c \
+ glsl_parser.ypp glsl_lexer.lpp glsl_parser_extras.cpp \
+ ast_expr.cpp
+# ast_to_hir.cpp ir.cpp hir_field_selection.cpp
+
+BUILT_SOURCES = glsl_parser.h builtin_types.h
+
+glsl_parser.h: glsl_parser.ypp
+
+.lpp.cpp:
+ $(LEXCOMPILE) --outfile="$@" $<
+
+builtin_types.h: builtin_types.sh
+ sh ./builtin_types.sh > builtin_types.h