summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2010-05-11 11:31:09 -0700
committerEric Anholt <eric@anholt.net>2010-06-01 15:15:04 -0700
commitb145e903694fa932ab1e0d955e889555193ab604 (patch)
treece6f4aab586b6fcffde5820242f127be9814f58c /Makefile.am
parentf8bb17260a6afb48534ec70dc9d5584851d7e3c2 (diff)
ir_vec_index_to_swizzle: Pass to convert indexing of vectors to swizzles.
This should remove the burden of handling constant vector indexing well from backend codegen, and could help with swizzle optimizations.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 42f0ae5..c31f396 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -47,7 +47,8 @@ glsl_SOURCES = \
ir_reader.cpp s_expression.cpp \
ir_hv_accept.cpp \
ir_hierarchical_visitor.h \
- ir_hierarchical_visitor.cpp
+ ir_hierarchical_visitor.cpp \
+ ir_vec_index_to_swizzle.cpp
BUILT_SOURCES = glsl_parser.h glsl_parser.cpp glsl_lexer.cpp
CLEANFILES = $(BUILT_SOURCES)