summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric Anholt <eric@anholt.net>2010-05-05 10:37:25 -0700
committerEric Anholt <eric@anholt.net>2010-05-05 11:08:18 -0700
commit6255a1f4c6425aa311c90e9dc7fca41c34e8dc2b (patch)
tree8863a17247b1802f09113c5ac4517879311e567a /Makefile.am
parentdc1dbd65e1099d98a05302e4ee67bc84c59a1386 (diff)
ir_dead_code_local: Remove redundant assignments within basic blocks.
This cleans up a bunch of junk code in some of the GLSL parser tests, and could potentially help real-world too (particularly after copy propagation has happened).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 49c3f4d..8f2f3fa 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -37,10 +37,13 @@ glsl_SOURCES = \
ir_copy_propagation.cpp \
ir_copy_propagation.h \
ir_dead_code.cpp \
+ ir_dead_code.h \
+ ir_dead_code_local.cpp \
ir_expression_flattening.cpp \
ir_function_can_inline.cpp \
ir_function_inlining.cpp \
ir_if_simplification.cpp \
+ ir_optimization.h \
ir_reader.cpp s_expression.cpp \
ir_visit_tree.cpp \
ir_visit_tree.h