summaryrefslogtreecommitdiff
path: root/src/gallium/drivers/lima/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/drivers/lima/Makefile.am')
-rw-r--r--src/gallium/drivers/lima/Makefile.am16
1 files changed, 15 insertions, 1 deletions
diff --git a/src/gallium/drivers/lima/Makefile.am b/src/gallium/drivers/lima/Makefile.am
index 4157aec716..881ecd509e 100644
--- a/src/gallium/drivers/lima/Makefile.am
+++ b/src/gallium/drivers/lima/Makefile.am
@@ -29,6 +29,13 @@ AM_CFLAGS = \
$(GALLIUM_DRIVER_CFLAGS) \
$(LIBDRM_CFLAGS)
+AM_CXXFLAGS = \
+ -I$(top_srcdir)/include/drm-uapi \
+ -I$(top_builddir)/src/compiler/nir \
+ -I$(top_srcdir)/src/compiler/nir \
+ $(GALLIUM_DRIVER_CXXFLAGS) \
+ $(LIBDRM_CXXFLAGS)
+
noinst_LTLIBRARIES = liblima.la
liblima_la_SOURCES = $(C_SOURCES)
@@ -36,13 +43,20 @@ liblima_la_SOURCES = $(C_SOURCES)
noinst_PROGRAMS = lima_compiler
lima_compiler_SOURCES = \
- lima_compiler_cmdline.c
+ standalone/lima_compiler_cmdline.c \
+ standalone/glsl.cpp
lima_compiler_CFLAGS = \
$(AM_CFLAGS) \
-I$(top_srcdir)/src/mesa \
-I$(top_srcdir)/src/mapi
+lima_compiler_CXXFLAGS = \
+ $(AM_CXXFLAGS) \
+ -I$(top_srcdir)/src \
+ -I$(top_srcdir)/src/mesa \
+ -I$(top_srcdir)/src/mapi
+
lima_compiler_LDADD = \
liblima.la \
$(top_builddir)/src/gallium/auxiliary/libgallium.la \