summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEmil Velikov <emil.velikov@collabora.com>2016-12-07 14:32:45 +0000
committerEmil Velikov <emil.l.velikov@gmail.com>2017-05-19 19:46:54 +0100
commit63e11ac2b5c99fa351be5f61a035f72384609a1c (patch)
tree1c9b80b7ea49f9e88e68eede0d5a61cec04d1c20 /configure.ac
parent912f24fd32f0e1e8731d9ae9afb916b076b93369 (diff)
configure: error out if building VA w/o supported platform
A bit pedantic patch to fool proof should someone start thinkering without knowing what they do. Cc: <mesa-stable@lists.freedesktop.org> Signed-off-by: Emil Velikov <emil.velikov@collabora.com> Reviewed-by: Eric Engestrom <eric.engestrom@imgtec.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 10 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cd66101c3d..90b70a62a9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2062,6 +2062,12 @@ if test "x$enable_xa" = xyes; then
fi
AM_CONDITIONAL(HAVE_ST_XA, test "x$enable_xa" = xyes)
+if echo $platforms | grep -q "x11\|drm\|wayland"; then
+ have_va_platform=yes
+else
+ have_va_platform=no
+fi
+
dnl
dnl Gallium G3DVL configuration
dnl
@@ -2078,7 +2084,7 @@ if test -n "$with_gallium_drivers" -a "x$with_gallium_drivers" != xswrast; then
PKG_CHECK_EXISTS([libomxil-bellagio >= $LIBOMXIL_BELLAGIO_REQUIRED], [enable_omx=yes], [enable_omx=no])
fi
- if test "x$enable_va" = xauto; then
+ if test "x$enable_va" = xauto -a "x$have_va_platform" = xyes; then
PKG_CHECK_EXISTS([libva >= $LIBVA_REQUIRED], [enable_va=yes], [enable_va=no])
fi
fi
@@ -2121,6 +2127,9 @@ fi
AM_CONDITIONAL(HAVE_ST_OMX, test "x$enable_omx" = xyes)
if test "x$enable_va" = xyes; then
+ if test "x$have_va_platform" != xyes; then
+ AC_MSG_ERROR([VA requires at least one of the x11 drm or wayland platforms])
+ fi
PKG_CHECK_MODULES([VA], [libva >= $LIBVA_REQUIRED])
gallium_st="$gallium_st va"
fi