summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChad Versace <chad.versace@intel.com>2015-08-27 22:33:54 -0700
committerChad Versace <chad.versace@intel.com>2015-08-27 22:53:03 -0700
commitc86ae0eb7b1d2e1227f35ad56db8512aad595bea (patch)
tree45308f32c61da0e0a7d30938fa92e52ee9533eb9 /Makefile.am
parent8d17b73473245907b2209551423fcf8e18acdaaf (diff)
tests: Add stencil_triangles
Add some tests that draw three overlapping triangles with a stencil buffer. Each test has a reference PNG for color and stencil. The full testname pattern is: func.depthstencil.stencil-triangles .clear-{}.ref-{} .compare-op{}.pass-op-{}.fail-op{} All tests pass on my local branch of Mesa with improved stencil support. I verified about the reference images of about a dozen tests (paying closer attention to invert ops) before I got bored and trusted that the remaining were also correct.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index bb77b5b..8c99e6f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -76,6 +76,7 @@ bin_crucible_SOURCES = \
src/tests/func/cmd-buffer/secondary.c \
src/tests/func/copy/copy-buffer.c \
src/tests/func/depthstencil/basic.c \
+ src/tests/func/depthstencil/stencil_triangles.c \
src/tests/func/desc/dynamic.c \
src/tests/func/draw-indexed.c \
src/tests/func/query/timestamp.c \
@@ -103,6 +104,8 @@ bin_crucible_SOURCES = \
BUILT_SOURCES = \
src/qonos/qonos_pipeline-spirv.h \
src/tests/func/depthstencil/basic-spirv.h \
+ src/tests/func/depthstencil/stencil_triangles-spirv.h \
+ src/tests/func/depthstencil/stencil_triangles_gen.c \
src/tests/func/desc/dynamic-spirv.h \
src/tests/func/draw-indexed-spirv.h \
src/tests/func/first-spirv.h \