summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorNanley Chery <nanley.g.chery@intel.com>2016-07-08 14:17:05 -0700
committerNanley Chery <nanley.g.chery@intel.com>2016-07-15 14:54:18 -0700
commit60f03520dfc6e9b7cbf3baa1aa4589b58ccc480a (patch)
tree4e557a433fd37d4405ac18bba8f9216e6e035596 /Makefile.am
parentb9a66d3f7ed73d9b91bba917eb203ef2fdfceda9 (diff)
Add tests for binding descriptor sets
This test isolates a bug in mesa 0f7a6ea5e7b95cfe10dd5c176858ca078b36a197 , where the driver segfaults when binding partly defined dynamic descriptor sets. This bug was discovered through func.desc.dynamic.storage-buffer. Signed-off-by: Nanley Chery <nanley.g.chery@intel.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 40e1d22..e2b3f42 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -80,6 +80,7 @@ bin_crucible_SOURCES = \
src/tests/func/depthstencil/basic.c \
src/tests/func/depthstencil/stencil_triangles.c \
src/tests/func/desc/dynamic.c \
+ src/tests/func/desc/binding.c \
src/tests/func/draw-indexed.c \
src/tests/func/event.c \
src/tests/func/gs/basic.c \