summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChad Versace <chad.versace@intel.com>2015-08-06 11:28:13 -0700
committerChad Versace <chad.versace@intel.com>2015-08-07 07:56:27 -0700
commit3a6f03e0e360a8552e84c42a6f139bc45218e027 (patch)
tree53cbb9d816445e8a2f66b6a5432ae7d00687f8d9 /Makefile.am
parent4be8b9f5556b826560a022831472d299d11380df (diff)
framework/test: Rewrite thread and phase transition code
Concurrency is hard, and this code was filled with bugs and race conditions. Concurrency is even harder when the code is spaghetti. Rewrite the code to be more straightforward and to make the test phase state machine easier to follow.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 302da9f..7e3d63b 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -57,6 +57,8 @@ bin_crucible_SOURCES = \
src/framework/test/t_cleanup.c \
src/framework/test/t_data.c \
src/framework/test/t_dump.c \
+ src/framework/test/t_phases.c \
+ src/framework/test/t_phase_setup.c \
src/framework/test/t_result.c \
src/framework/test/t_thread.c \
src/framework/test/test.c \