summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChad Versace <chad.versace@intel.com>2015-08-11 02:33:01 -0700
committerChad Versace <chad.versace@intel.com>2015-08-11 02:33:01 -0700
commit1e1cb2bef25033b1ff29e1b0f2ad48beed182c79 (patch)
treeefeb27cd6046058ff0471a285807d5dcdaa28b4e /Makefile.am
parent76bc86e14e6f2179da3f4da452bfe058aeb6c97e (diff)
runner: Support concurrent tests when using process isolation
Add the new option -j|--jobs to crucible-run that mimics the same GNU Make option. The default number of jobs is the number of online CPUs. Concurrent tests are not yet supported when using thread isolation mode. Using -j8 reduces a full testrun from 8s to 3.5s on my machine. This required a rewrite of the runner code.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6cb5b9e..94b88f2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -53,7 +53,9 @@ bin_crucible_SOURCES = \
src/cmd/main.c \
src/cmd/run.c \
src/cmd/version.c \
+ src/framework/runner/master.c \
src/framework/runner/runner.c \
+ src/framework/runner/slave.c \
src/framework/test/t_cleanup.c \
src/framework/test/t_data.c \
src/framework/test/t_dump.c \