summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJose Fonseca <jfonseca@vmware.com>2015-09-14 18:32:16 +0100
committerJose Fonseca <jfonseca@vmware.com>2015-09-14 18:32:16 +0100
commitb68e16a0af8e3977d1211437ff765a4020f6d272 (patch)
tree02672fcc69663af09a1eca33d4e82f6d06f93bad /CMakeLists.txt
parentf75d0ccc7275be86c2fae58c599e23af2f27db96 (diff)
cmake: Require Waffle when ENABLE_WAFFLE is set.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 3 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cdec80fe..7bdf573f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -153,12 +153,9 @@ else ()
endif ()
endif ()
-if (ENABLE_EGL AND (ANDROID OR ENABLE_WAFFLE))
- # if waffle is found eglretrace will be built for Android.
- find_package (Waffle)
- if (NOT ANDROID AND NOT Waffle_FOUND)
- message (WARNING "Could not find Waffle, disabling eglretrace")
- endif ()
+if (ENABLE_EGL AND ENABLE_WAFFLE)
+ # Use Waffle for eglretrace
+ find_package (Waffle REQUIRED)
endif ()