summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJonathan Morton <jmorton@sd070.hel.movial.fi>2009-06-15 16:02:04 +0300
committerJeff Muizelaar <jrmuizel@jeff-desktop.(none)>2009-06-15 13:49:25 -0400
commitb6a3868ced67eb363273bfbee0d850c4d06cca34 (patch)
tree7478fb6758c71f4d062a38388fb32ac1e6bf3ac0 /configure.ac
parent1217c11a02ef60a3955fd98f7cec48de4cb9561b (diff)
Better CFLAGS handling for recent ARM platforms.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 2 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 768f6b7..c410e62 100644
--- a/configure.ac
+++ b/configure.ac
@@ -327,7 +327,7 @@ AM_CONDITIONAL(USE_VMX, test $have_vmx_intrinsics = yes)
dnl ===========================================================================
dnl Check for ARM SIMD instructions
-ARM_SIMD_CFLAGS=""
+ARM_SIMD_CFLAGS="-march=armv6"
have_arm_simd=no
AC_MSG_CHECKING(whether to use ARM SIMD assembler)
@@ -366,7 +366,7 @@ AM_CONDITIONAL(USE_ARM_SIMD, test $have_arm_simd = yes)
dnl ==========================================================================
dnl Check for ARM NEON instructions
-ARM_NEON_CFLAGS="-mfpu=neon -mfloat-abi=softfp"
+ARM_NEON_CFLAGS="-mfpu=neon"
have_arm_neon=no
AC_MSG_CHECKING(whether to use ARM NEON)
@@ -470,8 +470,6 @@ AC_SUBST(GTK_LIBS)
AC_SUBST(DEP_CFLAGS)
AC_SUBST(DEP_LIBS)
-
-
AC_OUTPUT([pixman-1.pc
pixman-1-uninstalled.pc
Makefile