summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAndré Tupinambá <andrelrt@gmail.com>2009-09-19 09:32:37 -0400
committerSøren Sandmann Pedersen <sandmann@redhat.com>2009-10-26 13:04:21 -0400
commit88323c5abe68906472049537b54b0e7eea343f43 (patch)
tree2048231e5519690cdd31b88aebaff8541473f610 /configure.ac
parentf0c157f888185279681bad305973f246dca2e535 (diff)
Speed up bilinear interpolation.
Speed up bilinear interpolation by processing more than one component at a time on 64 bit architectures, and by precomputing the dist{ixiy} products on 32 bit architectures. Previously bilinear interpolation for one pixel would take 24 multiplications. With this improvement it takes 12 on 64 bit, and 20 on 32 bit. This is a small but consistent speedup on the swfdec-youtube benchmark: [ # ] backend test min(s) median(s) stddev. count Before: [ 0] image swfdec-youtube 18.010 18.020 0.09% 4/5 After: [ 0] image swfdec-youtube 17.488 17.584 0.22% 5/6 Signed-off-by: Søren Sandmann Pedersen <sandmann@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c3e339c..12c7f75 100644
--- a/configure.ac
+++ b/configure.ac
@@ -76,6 +76,8 @@ AC_CHECK_FUNCS([getisax])
AC_C_BIGENDIAN
AC_C_INLINE
+AC_CHECK_SIZEOF(long)
+
# Checks for Sun Studio compilers
AC_CHECK_DECL([__SUNPRO_C], [SUNCC="yes"], [SUNCC="no"])
AC_CHECK_DECL([__amd64], [AMD64_ABI="yes"], [AMD64_ABI="no"])