summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAdrian Bunk <adrian.bunk@movial.com>2009-07-20 20:16:32 -0400
committerSøren Sandmann Pedersen <sandmann@redhat.com>2009-07-20 20:16:32 -0400
commit767542cfb955ba22dad1259eff8a2fe16e7b8ba4 (patch)
tree62f15038e1cb9500caff960a5e76af429367932b /configure.ac
parent184cd80aa46dd9d8bd023d3b70a345330b72d7e7 (diff)
Fix NEON build for older ARM CPUs
The pld instruction used in the NEON assembler code is only available for ARMv5e and >= ARMv6. Set -mcpu=cortex-a8 when compiling the source file (similar to what is already done for the SIMD build).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 76cf691..5a49a6c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -384,7 +384,7 @@ AM_CONDITIONAL(USE_ARM_SIMD, test $have_arm_simd = yes)
dnl ==========================================================================
dnl Check for ARM NEON instructions
-ARM_NEON_CFLAGS="-mfpu=neon"
+ARM_NEON_CFLAGS="-mfpu=neon -mcpu=cortex-a8"
have_arm_neon=no
AC_MSG_CHECKING(whether to use ARM NEON)