summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorcompany <company>2003-12-03 18:29:30 +0000
committercompany <company>2003-12-03 18:29:30 +0000
commitd061113dcb4e217c32db01e156396d10724d0320 (patch)
treef4077c73d92b186ac05a3a960be036751ce807c0 /configure.ac
parentf7c4565a7fd85ca691d21bfba5f4b63b7aa6d0d9 (diff)
rewrite board handling, seperate UI and backend. Only visible change is automatic resizing when window is enlarged.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 2ccf5df..7b60046 100644
--- a/configure.ac
+++ b/configure.ac
@@ -33,6 +33,8 @@ AS_COMPILER_FLAG(-Wall, LIBGAME_CFLAGS="$LIBGAME_CFLAGS -Wall",)
if test "x$LIBGAME_CVS" = "xyes"; then
AS_COMPILER_FLAG(-Werror, LIBGAME_CFLAGS="$LIBGAME_CFLAGS -Werror",)
fi
+dnl no open shell on windows, plz
+AS_COMPILER_FLAG(-mwindows, LIBGAME_CFLAGS="$LIBGAME_CFLAGS -mms-bitfields",)
dnl required on gcc and windows - first is for gcc3, second for gcc2
AS_COMPILER_FLAG(-mms-bitfields, LIBGAME_CFLAGS="$LIBGAME_CFLAGS -mms-bitfields",)
AS_COMPILER_FLAG(-fnative-struct, LIBGAME_CFLAGS="$LIBGAME_CFLAGS -fnative-struct",)