summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2009-08-18 10:55:54 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2009-08-29 17:07:34 +0100
commit6e0b3be903a6c3ad948de95f490cff92430429a6 (patch)
treea4eddf60c33692885fb140eb93839569fcc990fb /configure.ac
parentc980affce05590f5f52273ba340463f00773c776 (diff)
Add cairo-sphinx utility for regression analysis
sphinx is an alternate version of the current cairo-test-trace. It's purpose is to replay a live application (which may just be a replay of a trace) against a backend and its reference. The improvement over the original cairo-test-trace is that the reference backend may be from an older version of cairo.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 31d79cfd..ec712f7d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -626,6 +626,11 @@ if test "x$have_bfd" = "xyes"; then
AC_SUBST(BFD_LIBS)
fi
+PKG_CHECK_MODULES(glib, glib-2.0, have_glib=yes, have_glib=no)
+AC_SUBST(glib_CFLAGS)
+AC_SUBST(glib_LIBS)
+AM_CONDITIONAL(BUILD_SPHINX, test "x$have_glib" = "xyes")
+
dnl ===========================================================================
AC_ARG_ENABLE(some-floating-point,
@@ -670,6 +675,7 @@ util/Makefile
util/cairo-fdr/Makefile
util/cairo-script/Makefile
util/cairo-script/examples/Makefile
+util/cairo-sphinx/Makefile
util/cairo-trace/Makefile
util/cairo-trace/cairo-trace
doc/Makefile