summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorArun Raghavan <arun.raghavan@collabora.co.uk>2011-12-19 10:16:05 +0530
committerArun Raghavan <arun.raghavan@collabora.co.uk>2011-12-19 10:16:05 +0530
commit5c4012482b15bd9ae32143b1563f43587116e8dd (patch)
tree7b50ef436bde3e7d44f7fb8daa7ba16ead58ab85 /configure.ac
parentdd3203206208775d415531498c96de2f46abb86b (diff)
build-sys: Fix map-file check
configure doesn't provide an abs_top_srcdir early enough, so we just use srcdir for that. There was also a problem with the path we were setting in VERSIONING_LDFLAGS that is fixed now.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index af30fd3b..b67b329a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -168,8 +168,8 @@ AS_CASE([" $CFLAGS "], [*" -O0 "*], [], [AX_APPEND_FLAG(["-DFASTPATH"], [CPPFLAG
# Check whether the linker supports the -version-script option.
# The Make variable $(srcdir) needs to be in the LDFLAGS in that form,
# so that it is expanded the right way in every subdir.
-AX_CHECK_LINK_FLAG(["-Wl,-version-script=${abs_top_srcdir}/src/map-file"],
- [VERSIONING_LDFLAGS='-Wl,-version-script=$(abs_top_srcdir)/map-file'])
+AX_CHECK_LINK_FLAG(["-Wl,-version-script=${srcdir}/src/map-file"],
+ [VERSIONING_LDFLAGS='-Wl,-version-script=$(abs_top_srcdir)/src/map-file'])
AC_SUBST([VERSIONING_LDFLAGS])
# Use immediate (now) bindings; avoids the funky re-call in itself.