summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlexandr Shadchin <alexandr.shadchin@gmail.com>2011-02-28 16:38:29 +0500
committerPeter Hutterer <peter.hutterer@who-t.net>2011-03-01 12:02:10 +1000
commitcf451f34e3bdd52a4eb072ce9f4b514eb83a1cfc (patch)
treece51028eaee777cb4c726e2c825ced777a45aeb1 /configure.ac
parentdce6006f6a851be4147e16731caa453dd0d1ec1c (diff)
Now ps2comm and alpscomm backend optional
Signed-off-by: Alexandr Shadchin <Alexandr.Shadchin@gmail.com> Reviewed-by: Peter Hutterer <peter.hutterer@who-t.net> Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 15 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index ea66935..edfc4e4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -98,21 +98,31 @@ AM_CONDITIONAL(DEBUG, [test "x$DEBUGGING" = xyes])
AC_MSG_CHECKING([which optional backends will be build])
case "${host}" in
*linux*)
- AC_MSG_RESULT([eventcomm])
+ AC_MSG_RESULT([ps2comm alpscomm eventcomm])
+ BUILD_PS2COMM="yes"
BUILD_EVENTCOMM="yes"
- AC_DEFINE(BUILD_EVENTCOMM, 1, [Optional backend eventcomm enabled])
;;
-*freebsd* | *openbsd* | *netbsd* | *dragonfly*)
- AC_MSG_RESULT([psmcomm])
+*freebsd* | *netbsd* | *dragonfly*)
+ AC_MSG_RESULT([ps2comm alpscomm psmcomm])
+ BUILD_PS2COMM="yes"
BUILD_PSMCOMM="yes"
- AC_DEFINE(BUILD_PSMCOMM, 1, [Optional backend psmcomm enabled])
;;
*)
AC_MSG_RESULT([none])
;;
esac
+if test "x$BUILD_EVENTCOMM" = xyes; then
+ AC_DEFINE(BUILD_EVENTCOMM, 1, [Optional backend eventcomm enabled])
+fi
+if test "x$BUILD_PSMCOMM" = xyes; then
+ AC_DEFINE(BUILD_PSMCOMM, 1, [Optional backend psmcomm enabled])
+fi
+if test "x$BUILD_PS2COMM" = xyes; then
+ AC_DEFINE(BUILD_PS2COMM, 1, [Optional backend ps2comm and alpscomm enabled])
+fi
AM_CONDITIONAL([BUILD_EVENTCOMM], [test "x${BUILD_EVENTCOMM}" = "xyes"])
AM_CONDITIONAL([BUILD_PSMCOMM], [test "x${BUILD_PSMCOMM}" = "xyes"])
+AM_CONDITIONAL([BUILD_PS2COMM], [test "x${BUILD_PS2COMM}" = "xyes"])
# -----------------------------------------------------------------------------
# Dependencies for synclient and syndaemon