summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHenrik Rydberg <rydberg@euromail.se>2010-12-30 20:51:35 +0100
committerHenrik Rydberg <rydberg@euromail.se>2011-01-02 09:18:44 +0100
commit41197333c6779832bd718fa55ed1b17d97e02304 (patch)
treeb907e56978a81305e838e52be366c95f11dcf549 /configure.ac
parent4b0f0873f91f7f37106fa39c6b8b5fa74f6a3dcc (diff)
Switch to autotools
To simplify the creation of packages for mtview, swtich to using the autoconf make tools. Signed-off-by: Henrik Rydberg <rydberg@euromail.se>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 33 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..b187080
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,33 @@
+# Initialize Autoconf
+AC_PREREQ([2.60])
+AC_INIT([Multitouch Viewer],
+ [1.0.0],
+ [],
+ [mtview])
+AC_CONFIG_SRCDIR([Makefile.am])
+AC_CONFIG_HEADERS([config.h])
+AC_CONFIG_AUX_DIR([config-aux])
+
+# Initialize Automake
+AM_INIT_AUTOMAKE([foreign dist-bzip2])
+AM_MAINTAINER_MODE
+
+LIB_VERSION=1:0:0
+AC_SUBST([LIB_VERSION])
+
+# Initialize libtool
+AC_PROG_LIBTOOL
+
+# Checks for programs.
+AC_PROG_CC
+AC_PROG_INSTALL
+
+PKG_CHECK_MODULES([MTDEV], [mtdev >= 1.1])
+PKG_CHECK_MODULES([EVEMU], [utouch-evemu >= 1.0])
+PKG_CHECK_MODULES([FRAME], [utouch-frame >= 1.0])
+PKG_CHECK_MODULES([X11], [x11])
+
+AC_CONFIG_FILES([Makefile
+ tools/Makefile
+ mtview.pc])
+AC_OUTPUT