summaryrefslogtreecommitdiff
path: root/app-crypt/seahorse/seahorse-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/seahorse/seahorse-9999.ebuild')
-rw-r--r--app-crypt/seahorse/seahorse-9999.ebuild34
1 files changed, 20 insertions, 14 deletions
diff --git a/app-crypt/seahorse/seahorse-9999.ebuild b/app-crypt/seahorse/seahorse-9999.ebuild
index 3142995..e7af9e0 100644
--- a/app-crypt/seahorse/seahorse-9999.ebuild
+++ b/app-crypt/seahorse/seahorse-9999.ebuild
@@ -1,41 +1,44 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/seahorse/seahorse-2.26.1.ebuild,v 1.1 2009/05/14 08:53:16 nirbheek Exp $
EAPI="1"
-inherit eutils gnome2 gnome2-live
+inherit gnome2 gnome2-live
DESCRIPTION="A GNOME application for managing encryption keys"
-HOMEPAGE="http://www.gnome.org/projects/seahorse/"
+HOMEPAGE="http://www.gnome.org/projects/seahorse/index.html"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="avahi debug ldap libnotify"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="avahi debug doc ldap libnotify test"
RDEPEND=">=gnome-base/libglade-2.0
>=gnome-base/gconf-2.0
>=dev-libs/glib-2.10
>=x11-libs/gtk+-2.10
+ >=dev-libs/dbus-glib-0.72
+ >=gnome-base/gnome-keyring-2.25.5
net-libs/libsoup:2.4
+ x11-misc/shared-mime-info
+
+ net-misc/openssh
+ >=app-crypt/gpgme-1.0.0
|| (
=app-crypt/gnupg-1.4*
=app-crypt/gnupg-2.0* )
- >=app-crypt/gpgme-1.0.0
- net-misc/openssh
+
avahi? ( >=net-dns/avahi-0.6 )
- >=dev-libs/dbus-glib-0.72
- >=gnome-base/gnome-keyring-2.23.6
ldap? ( net-nds/openldap )
- libnotify? ( >=x11-libs/libnotify-0.3.2 )
- x11-misc/shared-mime-info"
+ libnotify? ( >=x11-libs/libnotify-0.3.2 )"
DEPEND="${RDEPEND}
sys-devel/gettext
>=app-text/gnome-doc-utils-0.3.2
>=app-text/scrollkeeper-0.3
>=dev-util/pkgconfig-0.20
- >=dev-util/intltool-0.35"
+ >=dev-util/intltool-0.35
+ doc? ( >=dev-util/gtk-doc-1.9 )"
DOCS="AUTHORS ChangeLog NEWS README TODO THANKS"
@@ -50,10 +53,13 @@ pkg_setup() {
$(use_enable avahi sharing)
$(use_enable debug)
$(use_enable ldap)
- $(use_enable libnotify)"
+ $(use_enable libnotify)
+ $(use_enable test tests)"
}
pkg_postinst() {
einfo "The seahorse-agent tool has been moved to app-crypt/seahorse-plugins"
einfo "Use that if you want seahorse to manage your terminal SSH keys"
+
+ gnome2-live_pkg_postinst
}