summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJim Evins <evins@snaught.com>2010-11-25 22:47:16 -0500
committerJim Evins <evins@snaught.com>2010-11-25 22:47:16 -0500
commit30419b26c459fd1a9339c1c8a0341fc43ea7308f (patch)
treede8919a2bf230de9006354d4a8b6fa8ef2e4f909 /configure.ac
parentf9d15efd6543ae69c821010751ef960d97877349 (diff)
Cleanup of build system.
- 'make distcheck' is now successful - Removed several old artifacts
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac35
1 files changed, 19 insertions, 16 deletions
diff --git a/configure.ac b/configure.ac
index 15173bb..9bb2e3b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,8 +1,24 @@
dnl Process this file with autoconf to produce a configure script.
-AC_PREREQ(2.63)
-AC_INIT([glabels],[2.3.0],[http://sourceforge.net/tracker/?func=add&group_id=46122&atid=445116])
+dnl ---------------------------------------------------------------------------
+dnl - GLABELS version
+dnl ---------------------------------------------------------------------------
+m4_define([glabels_major_version], [2])
+m4_define([glabels_minor_version], [3])
+m4_define([glabels_micro_version], [1])
+
+m4_define([glabels_version],
+ [glabels_major_version.glabels_minor_version.glabels_micro_version])
+
+dnl ---------------------------------------------------------------------------
+
+
+AC_PREREQ(2.64)
+AC_INIT([glabels],[glabels_version],
+ [http://bugzilla.gnome.org/enter_bug.cgi?product=glabels],
+ [glabels])
+
AC_CONFIG_SRCDIR(src/glabels.c)
AM_INIT_AUTOMAKE(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
@@ -31,10 +47,9 @@ GNOME_COMPILE_WARNINGS
AC_PATH_PROG(GLIB_GENMARSHAL, glib-genmarshal)
AC_PATH_PROG(GDK_PIXBUF_CSOURCE, gdk-pixbuf-csource)
-AC_PATH_PROG(UPDATE_MIME_DATABASE, update-mime-database)
-AC_PATH_PROG(UPDATE_DESKTOP_DATABASE, update-desktop-database)
AC_PATH_PROG(GTK_UPDATE_ICON_CACHE, gtk-update-icon-cache)
+
dnl ---------------------------------------------------------------------------
dnl - GLABELS branch
dnl ---------------------------------------------------------------------------
@@ -288,18 +303,6 @@ fi
dnl ---------------------------------------------------------------------------
-dnl - Disable updating of mime and desktop databases
-dnl ---------------------------------------------------------------------------
-AC_ARG_ENABLE(update-mimedb, AS_HELP_STRING([--disable-update-mimedb],[disable the update-mime-database after install [default=no]]),,
- enable_update_mimedb=yes)
-AM_CONDITIONAL(ENABLE_UPDATE_MIMEDB, test x$enable_update_mimedb = xyes)
-
-AC_ARG_ENABLE(update-desktopdb, AS_HELP_STRING([--disable-update-desktopdb],[disable the update-desktop-database after install [default=no]]),,
- enable_update_desktopdb=yes)
-AM_CONDITIONAL(ENABLE_UPDATE_DESKTOPDB, test x$enable_update_desktopdb = xyes)
-
-
-dnl ---------------------------------------------------------------------------
dnl - i18n support
dnl ---------------------------------------------------------------------------
GETTEXT_PACKAGE=${GLABELS_BRANCH}