summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorpfaedit <pfaedit>2007-08-19 01:42:09 +0000
committerpfaedit <pfaedit>2007-08-19 01:42:09 +0000
commit6bbea560046d5440e85b91e42debec8526626797 (patch)
treeef9b4e1beb1da33190e4632f90f7ad6f70a43177 /configure.in
parent2538e91fde23566a6f4d0b906f0a85a41a23c7db (diff)
Back out the patch which brought up a thread to run a validator in the background while the user dawdled over the font save dlg. My allocation routines are not thread safe -- and I have an inexplicable crash to prove it.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 61277ab7..f6348f28 100644
--- a/configure.in
+++ b/configure.in
@@ -298,8 +298,10 @@ if test "$ac_cv_lib_freetype_FT_New_Memory_Face" = "yes" ; then
AC_CHECK_LIB(freetype, TT_RunIns, gww_hasbytecode="yes", : )
])
fi
-AC_CHECK_LIB(pthread, pthread_create, LIBS="$LIBS -lpthread", gww_hasbytecode="no")
-AC_CHECK_HEADERS([pthread.h], : , gww_hasbytecode="no")
+if test "$gww_hasbytecode" = "yes" ; then
+ AC_CHECK_LIB(pthread, pthread_create, LIBS="$LIBS -lpthread", gww_hasbytecode="no")
+ AC_CHECK_HEADERS([pthread.h], : , gww_hasbytecode="no")
+fi
if test \( "$gww_hasbytecode" = "yes" \) -a \( "$FreeType2_IncRoot" != "" \); then
gww_hasbytecode="no"