summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorpfaedit <pfaedit>2009-09-12 03:00:03 +0000
committerpfaedit <pfaedit>2009-09-12 03:00:03 +0000
commit617a5f5892531756f629b3166f15f3c128e22231 (patch)
tree02c45788431d7edea96a64025638f2f93a682dad /configure.in
parent17a1073b9ba17d935a5464ba56880a1cf753bed8 (diff)
More work on configure for 10.6
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 12 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 00d80919..818e0928 100644
--- a/configure.in
+++ b/configure.in
@@ -58,6 +58,8 @@ AC_ARG_WITH(static-imagelibs,
])
+oldCPPFLAGS="$CPPFLAGS"
+gww_extraincludes=""
oldLDFLAGS="$LDFLAGS"
LDFLAGS="$LDFLAGS -L/usr/local/lib"
@@ -69,6 +71,9 @@ case "$host" in
AC_DEFINE(__Mac,1)
MACAPP=FontForge.app/Contents/Info.plist
gww_define_caps_for_alt="1"
+ if test "$no_x" = "yes"; then
+ MACAPP=""
+ fi
dnl fink puts stuff under /sw
dnl macports puts stuff under /opt/local
@@ -79,8 +84,10 @@ dnl library to be found (otherwise only portable to machines with macports/fink
TrustUser="yes"
elif test -d /sw/include >/dev/null ; then
CPPFLAGS="$CPPFLAGS -idirafter /sw/include"
+ gww_extraincludes="/sw/include"
elif test -d /opt/local/include >/dev/null ; then
CPPFLAGS="$CPPFLAGS -idirafter /opt/local/include"
+ gww_extraincludes="/opt/local/include";
fi
rmlibs=""
if test "$oldLDFLAGS" \!= "" >/dev/null ; then
@@ -672,6 +679,10 @@ AC_ARG_WITH(regular-link,
rmlibs=""
AC_DEFINE(NODYNAMIC)
gww_rpath=""
+ if test "$gww_extraincludes" != "" ; then
+ CPPFLAGS=`echo $CPPFLAGS | sed -e "s%-idirafter $gww_extraincludes%%"`
+ CPPFLAGS="$CPPFLAGS -I$gww_extraincludes"
+ fi
fi
], : )
@@ -1003,7 +1014,7 @@ if test -e gtkui/Makefile.in -a \( -e /usr/include/gtk-2.0/gtk/gtk.h -o -e /sw/i
fi
if test "$rmlibs" != "" ; then
- LDFLAGS=`echo $LDFLAGS | sed -e "s/$rmlibs//"`
+ LDFLAGS=`echo $LDFLAGS | sed -e "s%$rmlibs%%"`
fi