summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorpfaedit <pfaedit>2008-07-29 00:48:20 +0000
committerpfaedit <pfaedit>2008-07-29 00:48:20 +0000
commit4eb7502b12b46e43163302e84e60fc29d3184573 (patch)
tree7f466497d3854e0e1f94ad8f9f4dcb29134bdcaa /configure.in
parent4f44d8790125efe6efbfc2e7511655a97860ee0b (diff)
Redo the mac application. Get rid of the macshell (a separate little proge which translated apple events into something fontforge could handle) and make it so fontforge itself can grok apple events if it is started from the finder.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 4b7bdf77..c7321455 100644
--- a/configure.in
+++ b/configure.in
@@ -44,9 +44,14 @@ case "$host" in
dnl fink puts stuff under /sw
- CPPFLAGS="$CPPFLAGS -I/sw/include"
- LDFLAGS="$LDFLAGS -L/sw/lib"
- gww_rpath="-rpath /sw/lib"
+ if test -d /sw/include >/dev/null ; then
+ CPPFLAGS="$CPPFLAGS -I/sw/include"
+ fi
+ if test -d /sw/lib >/dev/null ; then
+ LDFLAGS="$LDFLAGS -L/sw/lib"
+ gww_rpath="-rpath /sw/lib"
+ fi
+ LIBS="-Wl,/System/Library/Frameworks/Carbon.framework/Carbon $LIBS"
LIBS="-Wl,/System/Library/Frameworks/CoreServices.framework/CoreServices $LIBS"
dnl I would like to be able to just leave the framework as a filename. But
dnl if I do that, libtool eats it and gcc doesn't get it and ld doesn't get