summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authoraaron <aaron@7b491191-dbf0-0310-aff6-d879d4d69008>2007-06-09 20:46:34 +0000
committeraaron <aaron@7b491191-dbf0-0310-aff6-d879d4d69008>2007-06-09 20:46:34 +0000
commitdf3e986e9d9afd22de7f69055fc3dfd177916fc2 (patch)
tree08259dc59b0271edcbc4c972d3f340d03c81182a /Makefile.am
parentf000e050d9b5965db585c3be85f09a7972788a70 (diff)
Resync with DBMail 2.2.5
git-svn-id: https://svn.ic-s.nl/svn/dbmail/trunk/dbmail@2604 7b491191-dbf0-0310-aff6-d879d4d69008
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am10
1 files changed, 7 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index e412151a..8da2bcf8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -16,7 +16,11 @@
# along with this program; if not, write to the Free Software
# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
-SUBDIRS = modules man
+SUBDIRS = modules
+
+if MANPAGES
+SUBDIRS += man
+endif
if SIEVE
SIEVEPROGS = dbmail-sievecmd dbmail-timsieved
@@ -84,7 +88,7 @@ dbmail_util_LDADD = libdbmail.la
dbmail_users_SOURCES = user.c
dbmail_users_LDADD = libdbmail.la
-dbmail_export_SOURCES = export.c
+dbmail_export_SOURCES = export.c memblock.c dbmail-imapsession.c
dbmail_export_LDADD = libdbmail.la
dbmail_lmtpd_SOURCES = lmtp.c lmtpd.c
@@ -103,7 +107,7 @@ pkglib_LTLIBRARIES = libdbmail.la
if SHARED
-AM_LDFLAGS = -export-dynamic -lcrypt
+AM_LDFLAGS = -export-dynamic @CRYPTLIB@
libdbmail_la_SOURCES = $(COMMON) $(SERVER) $(DELIVER) $(MODULES)
else
libdbmail_la_SOURCES = $(COMMON) $(SERVER) $(DELIVER)