summaryrefslogtreecommitdiff
path: root/sci-geosciences/mod_tile/mod_tile-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/mod_tile/mod_tile-9999.ebuild')
-rw-r--r--sci-geosciences/mod_tile/mod_tile-9999.ebuild19
1 files changed, 16 insertions, 3 deletions
diff --git a/sci-geosciences/mod_tile/mod_tile-9999.ebuild b/sci-geosciences/mod_tile/mod_tile-9999.ebuild
index 3fd3ef5..d408fbd 100644
--- a/sci-geosciences/mod_tile/mod_tile-9999.ebuild
+++ b/sci-geosciences/mod_tile/mod_tile-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=4
-inherit apache-module subversion autotools
+inherit apache-module subversion autotools systemd
DESCRIPTION="a raster tiles service for example to use within a slippy map"
HOMEPAGE="http://wiki.openstreetmap.org/wiki/Mod_tile"
@@ -14,14 +14,15 @@ ESVN_REPO_URI="http://svn.openstreetmap.org/applications/utils/mod_tile/"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"
-IUSE=""
+IUSE="systemd"
DEPEND=">=sci-geosciences/mapnik-2.0
media-libs/freetype:2
>=dev-libs/icu-4.2
dev-libs/iniparser
sci-geosciences/mapnik-stylesheets"
-RDEPEND="${DEPEND}"
+RDEPEND="${DEPEND}
+ systemd? ( sys-apps/systemd )"
APACHE2_MOD_CONF="88_${PN}"
@@ -44,4 +45,16 @@ src_compile() {
src_install() {
default
apache-module_src_install
+ insinto ${APACHE_VHOSTS_CONFDIR}
+ doins "${FILESDIR}"/tileserver_vhost.include
+ if use systemd; then
+ insinto $(systemd_get_unitdir)
+ doins "${FILESDIR}"/renderd.service
+ fi
+}
+
+pkg_postinst() {
+ einfo "The module was automatically enabled and can be used after restarting the apache"
+ einfo "webserver. A vhost include is provided as well. You can add it to your vhosts to"
+ einfo "get the default setup"
}