summaryrefslogtreecommitdiff
path: root/magnifier/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'magnifier/Makefile.am')
-rw-r--r--magnifier/Makefile.am7
1 files changed, 2 insertions, 5 deletions
diff --git a/magnifier/Makefile.am b/magnifier/Makefile.am
index 555dda0..f87ec46 100644
--- a/magnifier/Makefile.am
+++ b/magnifier/Makefile.am
@@ -69,11 +69,8 @@ GNOME_Magnifier_module_la_LIBADD = $(ORBIT_LIBS)
GNOME_Magnifier_module_la_SOURCES = \
GNOME_Magnifier-imodule.c
-# The X_LIBS must be searched first, since the DEPS_LIBS are setted by a call
-# to pkg-config and can contain a path to X libraries, other way the
-# functionalities finded during the test that setted X_LIBS can not be
-# presented in the final link.
-LDADD = $(X_LIBS) $(DEPS_LIBS) libgnome-mag.la $(POPT_LIBS) $(COLORBLIND_LIBS)
+# The X_LIBS must NOT be searched first or it breaks the build
+LDADD = libgnome-mag.la $(DEPS_LIBS) $(X_LIBS) $(COLORBLIND_LIBS) $(GS_OBJS)
serverinfodir= $(libdir)/bonobo/servers
$(server_in_files): $(server_in_files).in