summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorEmil Velikov <emil.l.velikov@gmail.com>2014-06-07 21:40:49 +0100
committerEmil Velikov <emil.l.velikov@gmail.com>2014-08-18 13:33:44 +0100
commita60be1856d6cec5d1c0432010ac07a5979fc4e2b (patch)
tree626324fb8d1137527128b9e2160d2ce65f23de86 /CMakeLists.txt
parentc14f3a6734391a8a1c65e54413e7874b9e86ab5e (diff)
cmake: don't use open_s with mingw
The function is part of the secapi, which is not available under WinXP. Building piglit with it will result in broken tests. Signed-off-by: Emil Velikov <emil.l.velikov@gmail.com> Reviewed-by: Brian Paul <brianp@vmware.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 36b06fc6e..5807f639a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -364,7 +364,9 @@ check_function_exists(asprintf HAVE_ASPRINTF)
check_function_exists(ffs HAVE_FFS)
check_function_exists(strchrnul HAVE_STRCHRNUL)
check_function_exists(strndup HAVE_STRNDUP)
+if(NOT MINGW)
check_function_exists(fopen_s HAVE_FOPEN_S)
+endif()
check_function_exists(setrlimit HAVE_SETRLIMIT)
check_include_file(sys/time.h HAVE_SYS_TIME_H)