summaryrefslogtreecommitdiff
path: root/src/gallium/drivers/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/gallium/drivers/Makefile.am')
-rw-r--r--src/gallium/drivers/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/gallium/drivers/Makefile.am b/src/gallium/drivers/Makefile.am
index 6a0a2472c1..f2e7da110f 100644
--- a/src/gallium/drivers/Makefile.am
+++ b/src/gallium/drivers/Makefile.am
@@ -25,7 +25,21 @@ endif
################################################################################
+if HAVE_IDENTITY_GALLIUM
+
+noinst_LIBRARIES+= identity/libidentity.a
+
+identity_libidentity_a_SOURCES = \
+ identity/id_objects.c \
+ identity/id_context.c \
+ identity/id_screen.c
+
+endif
+
+################################################################################
+
SUBDIRS = $(GALLIUM_MAKE_DIRS)
# FIXME: Remove when the rest of Gallium is converted to automake.
default: all
+